The Sims 3 – Patch 1.33 Fix

Posted on

The Sims 3

Last few days after the patch came out, I have been experiencing some trouble with it. Whenever I try to play, the game would freeze on me for a few seconds and then start running again. Its so annoying as it cuts into a lot of my time after work (which is not much >.<)

I’ve tried looking for solutions online in the forums but no one has come up with a solid answer. I know for sure it has nothing to do with my computer as it was running fine before. But anyways, here’s my computer specs which my husband just build for me about a month back:-

  • Gigabyte A75m-D2H Motherboard
  • AMD A8-3870K APU
  • Plextor PX-128M3 SSD
  • G.SKILL F3-12800CL9d-8GBRL Ripjaws 8GB DDR3 1600 F

I’ve tried un-installing and re-installing and nothing worked. So in the end, I tried clearing the game cache and it fixed it. Here’s how to do it.

  • Go to the directory where your The Sims 3 is installed. Mine is in my Documents folder but you could probably find it under
    • Windows Vista/Windows 7: C:Users(username)DocumentsElectronic ArtsThe Sims 3
    • Windows XP: C:Documents and Settings(username)My DocumentsElectronic ArtsThe Sims 3
  • Delete the following files below
    • CASPartCache.package
    • compositorCache.package
    • scriptCache.package
    • simCompositorCache.package
  • Run your game like normal

After deleting the cache, the game will still have that constant freeze for a period of time as it has to build up the cache again but after a while, it will run smoothly like before. I think mine took about an hour or so but I wasn’t really paying attention.

I was just forcefully trying to play through the constant freeze and it just started working smoothly. Now I can play my Sims like normal again! On a random note, I forgot to set the option of no aging for my Sim and now she’s an old lady =(